Mission Communications - Mission SCADA System Restored – Incident details

Mission SCADA System Restored

Resolved
Operational
Started 7 months agoLasted about 4 hours

Affected

Cellular Carriers

Partial outage from 6:35 PM to 10:09 PM

AT&T

Partial outage from 6:35 PM to 10:09 PM

Telenor

Partial outage from 6:35 PM to 10:09 PM

Verizon

Partial outage from 6:35 PM to 10:09 PM

Data

Operational from 6:35 PM to 10:09 PM

Inbound

Operational from 6:35 PM to 10:09 PM

Updates
  • Resolved
    Resolved

    Mission SCADA System Restored

    Dear Valued Customer, 

    We are pleased to inform you that the Mission SCADA system is fully operational again. Remote monitoring and control have been restored, and our Engineering team will continue to monitor system performance over the next 72 hours to ensure stability. 

    Thank you for your patience and understanding over the past day as we restored services. If you have any questions, please contact our Technical Support team at 1-877-993-1911. 

    For future updates, follow us on X (formerly Twitter): @123mc

    Kind regards, 
    Mission Communications 

  • Identified
    Identified

    Dear Valued Customer, 

    We want to provide you with an update regarding the ongoing system network issue. Our Engineering team is continuing to work diligently to resolve the problem and restore full functionality to our services. 

    Please be assured that resolving this issue remains our top priority, and we will continue to monitor the situation closely until the system is stable. 

    We will share additional updates as new information becomes available. For updates, please follow our X (formerly Twitter) account: @123mc. 

    If you have any questions or need assistance, please contact our Technical Support team at 1-877-993-1911. We appreciate your continued patience and understanding as we work toward a resolution. 

     

    Thank you, 
    Mission Communications